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2. About this Quick Start Guide

The Switch Quick Start Guide explains the basic concepts of Switch and helps you to get started
with Switch.

The Guide consists of three parts:
e Understanding Switch on page 6 explains what Switch is and how it works, without going
into detail. Read this part if you're new to Switch.

e Getting started on page 15 guides you through installation and activation and explains how
to set up your first flow.

e Working with Switch on page 42 elaborates on some specific topics, such as using sample
jobs, working with folders and connecting different flows.

This Quick Start Guide contains a number of exercises. Try to make them yourself, before
checking the example solution.

Do you want to know more?

Please refer to the Switch Reference Guide, available on the Enfocus website.

Tip: You can also access the help files from within Switch: press F1 or select Help >
Switch help.
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3. Understanding Switch

Read this part if you want to know what kind of application Switch is, and how it works.

3.1. About Switch

Switch is an application that allows you to automate a number of tasks and processes, such as
sorting and renaming files, converting files to PDF, preflighting PDFs, and so on.

Every aspect of the process can be automated:

e Switch can pick up input files wherever you stored them.
e The tasks are executed without any manual intervention.
* Processed files are automatically placed in the appropriate location.

Working with Switch can save you a lot of time.

Modules

Switch is a modular application. It consists of:

» A core engine module, which offers the basic functionalities (sorting, renaming, splitting,
merging, ... files).

¢ A number of additional modules, which you can purchase if you need more advanced

functionalities.

For example, if you want to use Switch to automate tasks performed by third party applications
(such as the Adobe Creative Suite], you need a license for the Switch Configurator module; if you
want to use database information in Switch, you need the Database Module.

For a complete overview, refer to the Switch Reference Guide.

Components
Switch consists of the following components:

e Switch Server is the core engine; it runs in the background, executing all processes. It has
no user interface and it is started and terminated by the Switch Designer.

e Switch Designer is the user interface of Switch; the component you're using when working
with Switch.

e Switch Web Portal allows you to connect to the Switch Server through a web browser
interface, for example to view log messages or to submit and check jobs without having to
use a Switch Designer.

e Switch Web Services takes care of all data communication between Switch and its client
applications (the Switch Web Portal, our customers' own clients etc.). It's part of the default
Switch installation.

e SwitchScripter is a separate application for use with Switch: it allows you to create and
test scripts for Switch. Note that you can only use SwitchScripter if you have licensed the
Scripting Module.
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3.2. About working with Switch

Switch

Switch provides you with a workspace with a canvas and a number of tools (called flow elements)
to design your own workflows (called flows).

To create such a flow, you must select the flow elements you need from the right pane, and drag

and drop them onto the canvas.

Enfocus Switch - Ann's Switch Server (localhost) = E
File Edit Flow View Help
L
Ed [ul M e W ¥ b & @
Workspace Messages Statistics Save flow Rewert flow Impart faw Dedete o Dacument faw Fetry
Flows [ Flow elements
@ (@) & FLOW C
Hame ® ~ . | Favorites
Sortioh_OFmetadata_upd b s ELEMENTS)|
- ke Erablem jobs I Tocls
SwitchClient Flow I Scripting
> TEST — I Communication
test with pitstop server snfy v BhEs ~ Configurators B
b trash —_— - +  Workflow connectivity
Tutarial 1Fow (1) - ~5_ Automation Engine Confi..,
Input 1 Sart for FOF -~ ) SmantsStream Production ...
= Image Optimization ]
P Tutorial 2Fiow 1 All other files i~ Adobe Acrobat Professional
Tutorial 3 = R Adobe Photoshop
Tutorial 34 Flow CA N VA s g Apago PDF Enhancer
Elgical Clare
Properties 8 X Jobs 8 x ® Elpical Claro Premedia Sex..
Property Va Size Name 1 “p VIESUS
= it = Preflight and PDF
Hame F |
- T | 8 Input1 (0] if i~ Adobe Acrobat Professional
Description Cr
Background i Q Apago PDF Enhancer
e Mg o Apago PDFspy
Header image Nl m » BP callas pdfToolbo: 7 Actions
Allow advanced performance tuning N =) callas pdfToclbox 7 Com
g i ) P P
Time-of-day window Mg ~ 4, callas pdfToclbox 7 Profiles
Day-of-week window Md TimeStamp Module Flow had |7 Enfocus PitStop Server
Day-of-month window Md|= @ Jobs-26 i 1 Enfocus PitStop Server PD...
5/4/2015 4:45:3... | Folder | Tutorial 2 Flow1 c- Gl"‘f“”"'“;‘l;:c BarProof
- hd onversion to
5/4/2015 4:45:5... | Folder | Tutorial 2 Flow 1 - W oo Acrobat Distiller
al L - b I Adobe Acrobat Professional
] nr 3 | Messages | Progress Dashboard |

3.2.1. Flows

A flow (in its basic form) consists of the following elements:

* Some kind of input (can be files or folders) submitted to Switch

e One or more processes to be executed or tasks to be performed (e.g. renaming files,
converting images, preflighting PDFs ...]
e Some kind of output (=processed files and/or folders)

Input folder

Rename job

CQutput folder
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Each of these elements is represented by a flow element, and the flow elements are
interconnected via so called Connections (arrows). The direction indicates how the files will
move [in this example from left to right].

3.2.2. Input

Switch allows you to process both single input files and file folders.

e Examples of input files: PDF files, MS Word files, all types of images ...
e Example of input folders: InDesign folders, a page layout with all images and fonts ...

Files and file folders that enter Switch and have to be treated as one entity are in Switch
referred to as "jobs”.

Ways to provide input
There are several ways to submit input to Switch:

e Manually: You can drag and drop your input files or folders onto an input folder element

on the canvas. This is handy to test flows.

e Automated: You can configure Switch to download the input from a server (an FTP server, an
e-mail server, or a network server), or to receive it via the Switch Web Portal.

Depending on the way you want to provide your input, you must select the appropriate flow
element:

If you want to submit files ... Use the following flow element

By dropping them onto the canvas
(manually) Folder

Note: Switch will take care of the
physical location of the submitted
files. This location is not editable,
as indicated by the small lock that
appears on the Folder icon.

Via a location on a local computer or a
network server Folder (you will have to specify the
location)

M Iy
—% submit hierarchy

This is a special type which remembers the
folder structure. See The Submit hierarchy
flow element on page 54.

Via FTP )
FTP receive

Via e-mail
]
Mail receive
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If you want to submit files ... Use the following flow element
Via the Switch Web Portal -
v Submit point
Job data

Switch allows you to send extra data along with your input files, called Job data. This can be
metadata, the file name, information about the user, or data from other systems, such as MIS
systems, asset management systems... The format of the job data can be XML, JDF, Metadata...

Job data can be used to decide how files must be processed.
Example:

The paper type (coated versus uncoated) often determines whether or not a file must be sent to
an ink optimizer. If this information is available in your MIS system, you can attach it to your files
as job data. If the files arrives in Switch, Switch can use this information to sort the input files
and only send them to an ink optimizer application if required.

Uncoated Send to Ink Optimizer

]

Input via FTP
nput via Coated

3.2.3. Processes: standard processes

Switch provides you with a lot of flow elements for processing the files that are submitted to
Switch.

Some flow elements are always available, because they are included in the Switch Core Engine.
They allow you to perform a number of standard tasks/processes, such as the ones listed in the
table below.

Processes Flow element

Renaming a job or the files included in a job folder (e.g.

to add a prefix or a suffix, replace part of the name with @ _
Rename job

some other string, ...)

Sorting files in a job folder (for example renaming them

so that they are sorted alphabetically) E S
Sort files in jobs

Combining multiple PDF files into one file for processing, s
or splitting one file into different PDF files. Y

.27 Merge PDF
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Processes Flow element

N
I Split PDF

Moving files into a ZIP package, or extracting files from a —b}
— ) Archive

ZIP file.
i .
= ! Unarchive

Just like other flow elements, you can select these elements from the Flow elements pane.

Note: You can combine several processes in one flow. In the example below, the input is
first unzipped (using the Unarchive flow element) and afterwards merged into one PDF
file (using the Merge PDF flow element).

0 )

Input (zip) Unarchive unzipped files Merge PDF output (1PDF)

3.2.4. Processes: Configurators

If you have licensed the Configurator Module, a number of additional processes can be
performed, i.e. by 3rd party applications (Adobe Creative Suite, Adobe Acrobat Professional,
Automation Engine... ] integrated in Switch.

This is possible thanks to the Configurators, which allow you to connect to these applications
from within a Switch flow.

Configurators are available in the Configurators Category of the Flow elements pane, and must
be dropped onto the canvas, just like the other flow elements.

10
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Flow elements q X
I"Q' -"I| ﬁ1|'|
Favorites -
Basics
Tools
Scripting

Cu:ummunicat_iu:-n

Configurators
Workflow connectivity
‘%7 Auternation Engine Configurator
"E} SrnartStream Production Center JOF Control
Image Optimization
i~ Adobe Acrobat Professional
I8 Adobe Photoshop
Preflight and PDF
'~ Adobe Acrobat Professional
Enfocus PitStop Server
Enfocus PitStop Server PDF2Image
Conversion to PDF
P Adobe Acrobat Distiller
i~ Adobe Acrobat Professional
'ﬂ Adobe lustrator
! Adobe InDesign
P8 Adcbe Photoshop
»'% MadeToPrint lllustrator
% MadeToPrint InDesign
'}E Microsoft Excel
'"{" Microsoft PowerPoint
ﬁ Microsoft Word
Color Management

Enfocus PitStop Server
—

Note: You can only use Configurators for applications that you have installed and
licensed. Configurators for applications that are not available are hidden or displayed

in gray (depending on your settings - to change these settings, click in the upper
right corner of the pane).

How it works

Configurators allow you to send files to 3rd party applications from within a Switch workflow.
The sent files are processed by this application, and once processed, they are returned to
Switch, so that Switch can further process the resulting files as required.

In the example below, the input files are first sent to Photoshop for converting the images to
PDF; afterwards the resulting PDFs are sent to PitStop Server to be preflighted. The result of
the preflight (OK or not OK] is used to sort the output files.

1



Switch

O files

Jobs Photoshop FDF files Enfocus PitStop Server
Mok files

3.2.5. Processes: Apps

In Switch 13 update 1 the Switch apps were introduced: small applications that can be used as
flow elements in Switch, just like the Configurators, but without the need of a license for the
Configurator Module.

These apps are developed by Enfocus or 3rd party providers and can be purchased through the
Enfocus Appstore.

The purchased apps can be found in the Flow elements pane in a separate category, under
"Apps”, as shown below.

- Flow elements B X

:‘:l- json [_T] M

iApps
k=) JSON pickup

How it works
Once purchased and installed, apps are used just like other flow elements.

Note that you will receive notifications in Switch to inform you about your apps, for example if a
new version is available or if your subscription is about to expire. More information can be found
in the Switch Reference Guide, available on the Enfocus website.

3.2.6. Processes: connections

Whereas the flow elements are used to perform processes, the connections (= the lines between
flow elements) allow you to control the flow, i.e. to decide which files go where.

The connections can be configured to:

12
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e Hold files, or pass files through.
e Sort files by file type (for example PDF versus JPEG ), file size, file pattern or by condition
(author, color mode, and so on).

Example:

In the example below, the connections are configured to move the input files (based on their file
typel to the correct Configurator element. Input that does not comply with one of the configured
file types is moved to the “Other” folder and is (in this example) not processed.

- -. & -. — &
lustrator OK files
Ls
Input Photoshop FDF files Enfocus PitStop Server
- = =
Word Mok files
Other
Traffic light icons

If flow elements generate a report or log, i.e. indicate whether or not the input was processed
successfully (with or without warnings), this information can be used to sort the resulting
output.

For example, if PitStop Server (=a Configurator element) preflights PDF files, you can configure
the outgoing Connections in such a way that they include or exclude files based on their preflight
status. The color of the traffic light indicates which files are passed through:

e Green is used for files that are processed successfully.
e Yellow is used for files that generate a warning.

e Red is used for files that generate an error.
Example:

In the following example, the first connection moves files that were preflighted successfully
(green) or with warnings (yellow) to the Ok files folder, whereas the second connection moves
erroneous files (red) to the Nok files folder.

13
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O files

POF files Enfocus PitStop Server

Mok files

3.2.7. Output

Once the files have been processed, they are moved to an output folder. This can be a physical
folder somewhere on the network, a folder that's connected to another Switch workflow, or
an input folder for a RIP or print controller. You can also upload the output to an FTP or mail
server.

Depending on how you want to receive the output files, you can use one of the following flow
elements:

If you want to receive the processed output Use the following flow element
files...

In a folder on the network, or on your own
local computer Folder

D Archive hierarchy

This is a special type, which places the
output in a folder structure. See The Archive
hierarchy flow element on page 56.

t FTP send
L]
Mail send

Via an FTP server

Via an e-mail server

14
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4. Getting started

Read this part if you are new to Switch. You will learn:

e How to install and activate Switch.
e What the GUI looks like.
e How to create your first, basic flow.

4.1. Installing, activating and opening Switch

Before you can start working with Switch, you must first install Switch and activate the modules
for which you have a license.

Note that in this Quick Start Guide, only the main procedures are explained:

e We assume that you install Switch Server and Switch Designer on the same computer.
¢ We assume that this computer has internet access.

If this is not the case, for the appropriate procedures, refer to the Switch Reference Guide on the
Enfocus website.

4.1.1. Installing Switch

Prerequisites: You must have administrator rights on your local computer to install and run
Switch.

To install Switch

1. Do one of the following:

e Insert the Enfocus Product CD-ROM or DVD into your CD-ROM/DVD-ROM drive.
e Use the link you received from your local reseller to download Switch.

Switch is only sold via local resellers. Different from other Enfocus products, you cannot
download it directly from the Enfocus website.

2. If necessary, double-click the Switch installer.

3. Follow the on-screen installation instructions.
Make sure to install all Switch components (default installation).

You have installed Switch. Next, you have to activate your Switch license(s).

4.1.2. Activating Switch

Once you have installed Switch, you must activate the modules for which you have a license.

Note: You need at least a license for the Switch Core Engine. Other modules are
optional (and not required for the exercises in this Quick Start Guide).

15
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This procedure describes how to activate Switch on a computer with internet access.

Note: It is also possible to install Switch on a computer without internet access (but
you need to have another computer available to connect to the internet). For the offline
procedure, refer to the Switch Reference Guide.

To activate Switch

1.

Locate the application (Switch.exe or Switch.app) and double-click to start Switch.

Switch is installed by default in the following directory:

e Windows: C:\Program Files\Enfocus\Enfocus Switch <version number>

e Mac 0S: /Applications/Enfocus/Enfocus Switch <version number>

In the Connect to Switch Server dialog, select Connect to local Switch Server.

It is also possible to connect to a Switch Server installed on another computer (on which
Switch has been installed as well), but activation is only possible on a local Switch Server.
For more information, refer to the Switch Reference Guide.

Click OK.
The Switch Designer is opened and the Software Activation dialog appears.

Make sure the Off-Line Mode checkbox (in the top right corner] is cleared.

Enter your Enfocus ID and password.

If you don't have an Enfocus ID yet, click the Create Enfocus ID link and enter the required
information. Your account is created immediately, so you can proceed with the activation
procedure.

To supply your product key(s), do one of the following:

e Enter the product keys in the text area.
e Drop the product key file into the text area.
* Click Browse to select the product file from a location on your local system.

A green check mark next to the product key indicates that the key is valid.

Click Activate.
In the right part of the dialog, a green checkmark appears next to the activated module(s).

Click Close.

4.1.3. Opening Switch

This procedure assumes you are connecting to a local Switch Server.

To open Switch

1.

Locate the application (Switch.exe or Switch.app) and double-click to start Switch.

Switch is installed by default in the following directory:

e Windows: C:\Program Files\Enfocus\Enfocus Switch

e Mac 0S: /Applications/Enfocus/Enfocus Switch

16
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2.

If the Connect to Switch Server dialog pops up:

a.
b.

C.

Select Connect to local Switch Server.

Clear the Show dialog at startup checkbox.

Next time you open Switch, the selected connection (in this case: local connection) is
considered the default. You can afterwards still change the connection from within
Switch, by selecting File > Connect to Switch Server.

Click OK.

You have opened Switch.

Note: If you're launching Switch for the first time, the Switch Insight Dashboard dialog
pops up. Read the text carefully and click Yes, I'd like my Dashboard to get your own
personal dashboard. For more information, refer to the Switch Reference Guide.

4.2. The Switch workspace

When Switch Designer is launched for the first time, the following window (ie. the workspace] is

displayed.
B Eenfocus Switch - Ann's Switch Server (localhast) 1 =S}
File Edit Flow View Help 2
= = B L " Q
a - m & B i
Workspace Messages Statistics Users Mz flow Save flow Revert flow Impart fow Deicte flow  Document flow  — Activate flow Retry flaw
Flows F X s Flove elements 5 X
@ S i @ .
Name Glis R » Favorites B
— - | Prablem jobs + Basics
Add parfiad job name fo hierarchy._.
Add unique ID to job name = L Connection
3 archive ’ h 1
Archive By Date W Tt 4 Folder
Checkpoint via email NEW [_g .
- - Problem jobs
e Add Partial Job Name
CheckpointviaMai Telenet i —ﬁ Submit hierarchy
Extract even and odd pages Y | 7
Log job info in Excel —'j Archive hierarchy
Lag job info to Excel —f—ﬁ i p— =
New flow . = - ' _g Set hierarchy path
Froperties & x| bs 8% [21]] Job dismantler
Property || Name T s
| " " = Ungroup job
Hame 4 [d Output [1) T I
Description 5 4 b 00 Fil ] spiit mutti-job
Background image 5 20150622 ER_laatste schooldag,pdf po 2
Header image -2 | Bssemble job
Allow advanced performance tuning — |4
Time-of-day window 6 Generic application
Day-of-week window Enfocus Appstore
Day-of-month window
Go to the Enfocus Appstore
] il | K 1 b

It consists of a title bar and a menu/toolbar (#1 en #2) at the top, and a number of panes
(#3,#5,#6,#7) surrounding a central area, the canvas (#4). The table below gives a brief
description of each of these screen parts.

Screen part

Function

1 Title bar

Indicates whether or not you are connected locally or remotely. E.g.
Ann’s Switch Server (localhost) indicates that the Switch Server [in this

17
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Screen part  Function

example called Ann’s Switch Server] is launched locally. The name of the
Switch Server can be changed by selecting Edit > Preferences > Internal
Communication > Switch Server Name (Windows) or Enfocus Switch >

Preferences > Internal Communication > Switch Server Name (Mac 0S).

2 Menu/ The menu bar gives access to the different panes and functions of Switch;
Toolbar for some of the main functions a shortcut, i.e. a button is available in the
toolbar:

e The Workspace button allows you to switch between different
workspace views (i.e. combinations of panes). There are three
preconfigured views (Design - which is the default -, Run and Test),
but you can change the content of these views as required, by
displaying/hiding pane(s) via the file menu View > Show panes.

¢ The Messages, Statistics, and Users button allow you to switch to the
corresponding screens:

¢ Click Messages, to check the log messages. They will be shown in
a browser.

e Click Statistics, to learn more about the time needed for
processing the input files in a particular folder. Note that only
folders for which the property Show in statistics is enabled are
shown in this pane. (See About flow element properties on page
24)

e C(Click Users to determine which users are allowed to use Remote
Designer or have access to certain Checkpoints and Submit points
via the Switch Web Portal.

¢ The other buttons are used to work with flows (e.g. to save, activate,
document,... a flow)

Note: Not all buttons are available in all views. The above
described buttons are displayed in the default Workspace -
Design view.

3 Flows pane Gives an overview of the flows in your workspace. The selected flow is
shown on the canvas (#4).

The properties of the selected flow are shown in the Properties pane (#5).

4 Canvas Gives a visual representation of your flow and allows you to design flows.

5 Properties Gives an overview of the properties of the flow selected in the Flows pane
pane (#3) or the flow element selected on the Canvas (#4).

6 Jobs pane Shows the content of the backing folder of a selected flow element. This

allows you to see which files are where in the flow.

18
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Screen part  Function

7 Flow Contains all flow elements (including built-in tools, installed apps and
elements configurators) that can be used for designing flows.
pane

Note: The number of flow elements depends on the modules you
have licensed. For example, the Configurator elements are only
available if you have licensed the Configurator module.

When using the search function, matching results in the Enfocus
Appstore are displayed at the bottom of the pane.

4.3. Before you start

If you want to automate a process, we recommend analyzing the process in detail first.
Think about:
e Where the files/jobs come from (the input).

e What you want to do with them (processes).
e Where you want them to go (output).

Tip:

¢ Use diagrams to visualize your flows, before actually configuring them in Switch!

e Try to break down your workflows into smaller flows, focused on one task: it's much
easier to work with small flows than with large and complex flows, which are difficult
to debug.

4.4. Creating your first flow

Working with flows always requires the following steps:

1. Create a new flow for the process you want to automate. You can start from a blank flow
(and design it from scratch) or start from a sample flow.

2. Design your flow, by dragging the required flow elements onto the canvas. You must
configure the properties of all flow elements and connections on the canvas.

3. Runyour flow: i.e. save, activate and test the flow using test files, until you are happy with
the result.

4.4.1. Step 1: Creating your flow

Although you could also start from a sample flow, for your first flow(s), we recommend starting
from scratch (blank flow).

To create a blank flow

19
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1. Do one of the following:

In the toolbar at the top of the screen, click Mewflew

e From the menu, select Flow > New Flow....
e Inthe Flows pane, right-click and select New Flow.

A new flow is created. By default it is called "New flow" (followed by a number if it's not your
first "New flow").

2. Enter a meaningful new name for your flow.

Your cursor will automatically focus on the flow name in the Flows pane, so you can
immediately type a new name. If you click outside the name field, the name will be displayed
in italics and it will have an asterisk next to it, to indicate that the flow hasn't been saved yet.

You can now add flow elements as required.

4.4.2. Step 2: Designing your flow

4.6.2.1.

You are now ready to design your flow:

1. Add flow elements to the canvas.
2. Connect them through Connections.
3. Configure the flow element properties.

About flow elements

Flow element types
Remember the difference between the flow elements available in the Flow elements pane:
e The Connection flow element is a special type, connecting other flow elements and

determining how jobs (i.e. files and file folders) can move from one flow element to another.

e The Folder flow element can be used to deliver input files and to store the processed files,
but it is also used to (temporarily] store or modify jobs in between processes.
e Various other flow elements allow you to handle jobs.

For more information about the flow elements, refer to About working with Switch on page 7.

Search field

To find the flow element you need, you can use the Search field at the top of the Flow elements
pane.

Just enter a keyword, and the associated flow elements will be shown. For example, if you
enter the word preflight, you will see all flow elements that can be used to preflight jobs
(Enfocus PitStop Server, callas pdf Toolbox configurators) or to deal with preflighted jobs (Sort
by preflight state).
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Flow elements B X

':E':l. prefight ﬂ:‘ ﬁ‘,

E Enfocus PitStop Server
Eﬂ Sort by preflight state

5?' callas pdfToclbox 7 ConvertColors

g-l?lr callas pdfToclbox 7 Impose

'!‘E‘Qr? callas pdfToolbox 7 Profiles

Tooltips
Switch provides you with tooltips for every field or element in the GUI.

So, if you are not sure about the meaning of a flow element, move your cursor over it and a
tooltip will appear.

Flow elements g x
@ )
F Favorites -
b Basics B
ko Tools =
F Scripting

* Communication
[

"Il HTTP request

g 3

@ FTP receive

FTP receive is a producer that downloads files from an FTP site
and injects them into the flow.

uu Mail receive

r

Furthermore, to learn more about the Configurators and what they are used for, you can right-
click the Configurator and select Info on third-party application or Documentation.
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Configurators
Workflow connectivity E
< At"rgminﬂm;
I e Info on third-party application...
;E Smart _
= Documentation...
Image Optim
Add to favorites
_;_}51: Adobe
Search for all applications

D5 [T ———— o

Problem jobs

The Problem jobs folder element is a special element that keeps track of jobs that cannot be
processed. This is the case if a job matches none of the filters set on a Connection, if an invalid
file format is sent to a third party application configurator, and so on.

Always add this element to your flow; otherwise you may not be aware of the fact that there are
problems with your flow...

Note: The Problem jobs folder element does not require any connections. It can have an
outgoing connection that handles failed jobs, but if there is no outgoing connection, the
failed jobs stay in the folder until a user handles them manually.

Problem jobs

Trapped

Input Mot trapped

Trapped flag not defined

22



Switch

4.4.2.2.

4.4.2.3.

4.b.2.4.

Adding flow elements to your flow

You need at least one flow element for the input and one for the output; additional elements may
be required depending on the processes you want to automate.

Input and output: The most basic flow consists of two Folder elements, one for the input and
one the output (see example below), but depending on the way you want to deliver your input and
receive the output, you can select other elements, such as FTP Receive... (See Input on page 8
and Output on page 14).

Processes: A number of flow elements allow you to perform processes, such as Merge PDF,

Compress, ... See Processes: standard processes on page 9 and Processes: Configurators on page
10).

To add a flow element to your flow
Do one of the following:

e Drag the icon for the desired flow element from the Flow elements pane onto the canvas
in the desired location.

¢ Right-click a blank area of the canvas and select Add > <category> > <desired flow
element>.

Warning when adding flow elements

If you drop a flow element on the canvas, a warning icon may appear. To see what the problem
is, move your cursor over the icon and check the tooltip.

Input Rena job Cutput

Rename job

WWARMNIMNG:

- the flow element requires at least one
incoming connection

- the flow element requires at least one
outgoing connection

Note that in some cases additional information (warnings or errors) is available in the log
messages in the Log messages overview (See further: Troubleshooting problems when running a
flow on page 35).

Connecting flow elements

Next step is connecting the flow elements on the canvas, using the Connection flow element.
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4.4.2.9.

To connect two flow elements that are already present on the canvas
Do one of the following:

e Drag the Connection icon from the Flow elements pane and drop it onto the first flow
element; then click the second flow element.

e Double-click the first flow element; then click the second flow element.

e Right-click the first flow element and select Start connection; then click the second flow
element.

A connection line connects the two flow elements.

About flow element properties

After you have placed the required flow elements on the canvas, and connected them as
required, you must configure each flow element’s properties.

Properties pane
The Properties pane displays the properties of the selected flow element.
Each flow element type has its own specific properties.

For example, FTP receive has properties to identify the FTP server, whereas the Folder element
has a property for the file path.

Properties may also be different, depending on the flow element(s] the selected element is
connected to.

Example of the properties of an FTP receive flow element:
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FTP receive

Property
Name
Description
Server type

Passive mode
FTP server address
Port
User name
Password
FTP directory
Leave originals on server
Minimum file size (KB)
Check every (minutes)
Time-of-day window
Day-of-week window
Day-of-month window
Subfolder levels
Process these folders
Adjusted by (rule 1)
Adjusted by (rule 2)
Adjusted by (rule 3)
Adjusted by (rule 4)
Adjusted by (rule 5)
Attach hierarchy info
Attach email info
Allow subfolder cleanup

starting at level

Value

FTP receive

Receive input files from Enfocus FTP

FTP

Yes
ftp.enfocus.com
il

userl

iR

r
!

Mo

Mone

10

Mo

Mo

Mo

99

All Folders
Mone
Mone
Mone
Mone
Mone

Mo

Ernail info map defined

es
2

Example of the properties of a Folder flow element:

Properties

D Property Value
N dueut

Description processed files (POF)

Path Auto-managed

Color Yellow

Strip unique name Yes

Duplicates Add version nurmber

Separator

Switch

Tip: Remember that you can display a tooltip for each of the property fields.
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Default values

Switch fills the properties with meaningful/default values; you only have to specify values
that Switch cannot know (e.g. FTP/e-mail server address, user names and passwords, e-mail
addresses for notifications...) and values that are different from the default values.

Filters

Example of the properties of a Connection flow element:

Properties
—_—

Property Value
Hame
Description
Corner angle i}
Color Blue
Hold jobs Mo
Include these jobs All jobs
Exclude these jobs Mo jobs

The Connection properties allow you to filter, i.e. exclude or include particular files (or file
folders, depending on the connected elements) moving along the connection. Filter properties
can be used to sort files, based on file types, file patterns ... (see image below).

Properties B X
Property Yalue
Hame
Description
Corner angle ]
Color Elue
Heold jobs Ma
Include these jobs All jobs LE}'

Exclude these jobs )
All other jobs

Define file types

Define file patterns

Define regular expression
Define condition with variables

Define script expressicn

Example of a flow with filtering via the Connection properties
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(Sort by file extension (PDF))
|

Input Qutput
Properties

Property Value

Name Sort by file extension (PDF)

Description Only PDF

Corner angle ]

Color Magenta

Hold jobs Mo

Include these jobs File types defined

Exclude these jobs Mo jobs

In this example, only PDF files will be sent to the output folder; all other files will be sent to a
Problem jobs element. Alternatively, you could add a second output folder, to take care of the
non-PDF files. The connection to this second output folder should have the property Include
these jobs set to All other jobs.

To see which file types are defined, you must click the Include these jobs property, select File
types defined and check the dialog that pops up.

Tip: It's handy to mention the sorting method in the name of your Connection.

Hold jobs allows you to stop files from being routed to the next folder; the files remain in the
source folder, and you can check their properties via the Jobs pane. See About sample jobs on
page 43.

This also allows Switch to use the input as an example when defining variable parameters. For a
use case, see exercise 3.

Note: If a connection is set “on hold”, the connection is shown as an orange dashed line.

¥ PDF
]
Mail receive Input

Other
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4.4.2.6. Configuring flow element properties
To change the properties of a flow element

1. Select the flow element of which you want to change the properties.

Note: If you select multiple (similar) flow elements at the same time, you can
change the common properties.

The properties of the selected flow element(s) are displayed in the Properties pane.

2. Click the property you want to change.
Depending on the selected property, a text box, a button, or a drop-down menu appears.

3. Make the required changes:

If ... Do the following:

appears

A text box Type the text in the displayed text field.

A drop- Select the appropriate option.

down

menu

[3 1. In the the property editor dialog that pops up, update the field(s)
as required.
2. Click OK.

1. From the pop-up list, select one of the options.

Auko-managed
Inline value
Zhoose Folder

Depending on the selected option, an inline editor or a dialog
appears.

2. Configure the desired values.

Your changes are applied immediately.

4.4.2.7. Adjusting the layout of your flow design

If you have designed a flow with many flow elements, it is important to keep it clear and well-
arranged. Switch provides you with a number of tools to do this:

e You can align your flow elements (place them all on one line, horizontally or vertically).
e You can adjust the layout of the connections.
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e You can change the color of the connections and folders, for example to distinguish between
local and network folders.

Tip: For a better overview, we recommend using meaningful names for flow elements
and connections.

Example:

Before: Disorganized and sloppy...

]

Mail send
Ok
]
Mail receive -
Chedk single pages Problem jobs
MOK
After: A neat and well-arranged layout:
L
K Mail send

1 [

Mail receive Chedk single pages MOk Problem jobs

In the above example, the green color is used to indicate how the files should move if nothing
goes wrong.

Aligning flow elements horizontally
To align flow elements horizontally
1. Select the flow elements to be aligned.
2. Do one of the following:
e On Windows 0S:

Select Edit > Align Horizontally, or press Ctrl + Shift + H.
e 0On Mac 0S:

Select Enfocus Switch > Align Horizontally, or press Command + Shift + H.
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Aligning flow elements vertically
To align flow elements vertically
1. Select the flow elements to be aligned.

2. Do one of the following:
e On Windows 0S:

Select Edit > Align Vertically, or press Ctrl + Shift + V.
e 0On Mac 0S:

Select Enfocus Switch > Align Vertically, or press Command + Shift + V.

Adjusting the layout of a connection

By default, connections are drawn as straight lines between two flow elements. You can
however adjust these lines to make a well-arranged design.

1. To draw the connection along the sides of a rectangle (with a rounded corner]
a. Select the connection.
b. Do one of the following:

¢ Right-click the connection and select Vertical, then horizontal or Horizontal, then
vertical.

¢ Inthe Properties pane, set the connection’s Corner angle to -90 or +90.

2. Todraw the connection along a route somewhere in between these extremes
a. Select the connection.
b. Do one of the following:

¢ Move your cursor over the connections's corner until a drag handle (blue circle)
appears, and drag the handle to the desired direction.

¢ Inthe Properties pane, set the connection’s Corner angle to a value between -90 or
+90.
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Adjusting the colors of folders and connections

To make it easy to distinguish between different folder or connection types, for example
between network and input folders, you can change the default color for folders (yellow] and
connections (gray).

To adjust the colors of folders and connections

1. Select one or more connections or folders.

Note: You cannot combine connections and folders in one selection.

2. Right-click to open the context menu.

3. Click Choose color and select the appropriate color from the list of predefined colors.
You can choose one of the following colors:

e Gray (default], Yellow, Green, Cyan, Blue, Magenta for connections.
e Yellow (default), Orange, Green, Cyan, Blue, Magenta for folders.

e Orclick "Custom” and select the color of your choice using the color picker.
Alternatively, you can set the color via the Properties pane.

Keep in mind that "conditional” colors (e.g. orange for connections on hold) will take priority
over custom colors.
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For example, even if you have chosen green for a particular connection, its color will change to
orange when the connection is set on hold. When the connection is released, the chosen color
(green) will be restored.

4.4.3. Step 3: Running your flow

Once you have configured the flow elements, you can save, activate and test the flow, to see if it
does what you expect it to do. If this is not the case, Switch offers a couple of tools to investigate
what's going on, so you can solve the problems.

4.4.3.1. Saving a flow

In the Flows pane, unsaved flows are displayed in italics, followed by an asterisk.
To save a flow
1. Inthe Flows pane, select the flow you want to save.

Optionally, you can select several flows, to save them all in one go.
2. Do one of the following:

° [_ll

L3
In the toolbar at the top of the screen, click 52veflew

e Inthe Flows pane, right-click and select Save Flowl(s).
* From the menu, select Flow > Save Flow(s).

In the Flows pane, the flow name is no longer displayed in italics and the asterisk has
disappeared.

Note: As soon as you start making changes to the saved flow, the name is again
displayed in italics, followed by an asterisk. Note that you can always go back to the
last saved version, by clicking the Revert Flow button in the toolbar.

4.4.3.2. Activating a flow

If you want a flow to start processing jobs, you must activate it.

To activate a flow
1. Inthe Flows pane, select the (inactive) flow you want to start.
2. Do one of the following:

In the toolbar at the top of the screen, click Astivate flow

In the Flows pane, click I_*I and select Activate Flow.
* Inthe Flows pane, right-click and select Activate Flow.
e Inthe Flows pane, double-click the selected flow (only possible in case of a single flow).
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e From the menu, select Flow > Activate Flow.

If you haven't saved your flow yet and you haven't enabled automatic flow saving in the
Switch preferences, a warning pops up. Note that clicking Save, will save all flows with
unsaved changes. If you do not want to save all unsaved flows, click Cancel and manually
save the flows as required.

The background of the flow is darkened. In the Flows pane, you can see anicon ¥ nextto
the name of the flow. The flow is now active and waits for input jobs to appear.

4.4.3.3. Testing a flow

Input for testing
To test the flow, make sure to provide Switch with some meaningful input:
e Ifyou have chosen a Folder element for your input:
e Ifyou have entered a file path in the Folder element property Path, make sure it contains

some appropriate input files or folders.

e Ifyou haven't configured a path in the Folder element property Path, drag and drop the
input from your local computer onto the input element on the canvas.

Note: In that case, the value of Path is Auto-managed (which is the default value).
Auto-managed folders are folders that are created automatically (by Switch] in

the application data root folder. Note that the the path to the application data root
folder can be found in the Preferences > Application data > Application data root.

e [f you have chosen a Mail receive or an FTP receive flow element, make sure that some
input is available on the configured mail or FTP server.

e [f you have selected a Submit point, you must provide your input using the Switch Web Portal.
For more information, refer to the Switch Reference Guide.

Switch will process the input as soon as the flow is activated.

Information while processing

While the flow is running, Switch gives you information about the jobs being handled and their
progress:

e The number of jobs being present in a folder is indicated on the canvas. This allows you to
see how files move along a flow and where they are being hold.

If more than 100 jobs are present in a particular folder, Switch doesn't display the number,
but instead displays the symbol for infinity.
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(4
Archive copy Archive hierarchy
e
i
Submit hierarchy

Production copy Unarchive output

Problem jobs and problem processes are marked with an error mark icon.

I

Problem jobs

If the icon appears next to a Problem jobs folder, the Problem jobs folder contains at least
one file or file folder. This may be due to the fact that the job does not match the filters set on
a Connection element.

A

In Acrobat Professional Ot

If the icon appears next to a flow element for processes, there may be a problem with this
element, for example a network error (so jobs can no longer be transported), or an invalid
property.

If the icon appears next to a folder element, probably the backing folder is not accessible
anymore, for example because it does not exist anymore, or because the local network
connection is broken.

Output

Carefully check the output.

In case of problems:

[
3

Stop the flow, by clicking the Ztepflew putton.

2. Review the properties of the flow elements.
3. Activate the flow again, to see the result of your changes.

34



Switch

Tip: Not clear what the problem is? Have a look at Troubleshooting problems when
running a flow on page 35.

4.4.3.4. Troubleshooting problems when running a flow

In case of problems, have a look at the following panes.

The Log messages overview

The Log messages overview is actually not a pane, but a web page. It gives an overview

of all messages issued by the Switch Server. There are different types of messages, e.qg.
info messages, warning messages and error messages. Warnings are shown in an orange
background, errors in a red background.

You can filter the messages as required, for example by selecting a particular date or date
range, a particular time or by searching for a particular string.

4

Messages Yesterday v AT

1427
Message contains PitSlop Senver Massage containg ScriptExecutor

| m - f:;l Message ~ containg ]

Tirme Fleww b Elemen o

SwitchSripiExecuior process with 1D 13112 has been stopped because it has been inactive
13:35:00 for 1546 secands. Processing is not affecoed: a mew SwitchSoripiExecutor process will be
started when "-:'-.'r"r.'..1r:|-.

How to display the Log messages overview?
Do one of the following:

Ce

Click Mess2ges or

e Click View > Messages.

The Progress pane

This pane displays progress information for tasks currently being executed by the Switch
Server, for example downloading files from FTP or distilling a PostScript file.
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(x 1) Progress
Flow Element Task type Task category Job prefix Job Status Progress ProcessID 4 Time elapsed
Prepr... Folder 57  File system  Monitor Process... 1054 00:00:02
Prepr... Hold job Hold job Processor 00ONF log (.. Executi.. 1054 00:00:00
Prepr.. frommail Folder Disk O0ONI sub..  Jobarri... 1054 00:00:00
Prepr... File recei... Folder Disk DO0ONE PitSt... Moving ... 1054 00:00:00
Prepr... Hold job Hold job Processor Q0OND Enfo... Executi.. 2693 00:00:00
Prepr... Fake file.. Hold job Processor Q0ONB PitSt... Jobwa.. 0% 4505 00:00:00

How to display this pane?

From the menu, select View > Show panes > Progress.

The Dashboard pane

The Dashboard pane displays an overview of current problems with the flow (opposed to the
Messages pane, which gives an overview of problems in the past).

Dashboard B X
TimeSkamp Module Message Job Flow
- @ Jobs - 2
g/9/2007 10:07:54 AM |Folder Mo outgoing conneckion accepts this job | _0000M_IMG_8554,JPG | Color management
g/9/2007 10:07:54 AM | Folder Mo outgoing conneckion accepts this job |_0000L_IMG_8582,JPG | Color management
- Ef' File transfers - 1
|8,|'9,|'2EIEI? 2:01:20 &AM | Mail receive |Failed to connect ko mail server; error ..
w (& External processes - 0
£ >

How to display this pane?

From the menu, select View > Show panes > Dashboard.

4.9. Exercise 1: Sorting files by file type

Instruction

Create a flow where files can be placed manually in an input folder. Switch should sort the input
into two categories: PDFs and non-PDFs.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

e Review the step-by-step solution.

Check the result in your own copy of Switch. To do so, import Tutorial 1 Flow.sflow (included
in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.
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Have a look at the video explaining how to build this flow: http://youtu.be/u8BT8llg3RI.

4.5.1. Exercise 1: Solution

This topic explains how to create a basic flow, which sends all input files first to an intermediate
folder and then sorts them into two categories (PDFs versus all other files).

1.
2.

Open Switch.

Create a new blank flow and rename it to Tutorial 1 Flow.

a. Create a new blank flow.

b. Make sure the flow is selected and in the Properties pane, click the Name field.
c. Replace New flow 1 with Tutorial 1 Flow.

Add a Folder flow element (for the input), and configure the properties as required.
In this exercise, the input folder should be named /nput? and linked to a physical folder on
your desktop.

a. From the Flow elements pane, select the Folder flow element and drag it onto the blank
flow canvas.
As you drag the item onto the flow canvas, you should see it drag with your cursor. You
should place it on the left side of the canvas.

Select the folder on the canvas.
Change the name in the Properties pane to Input 1.
d. Link the Folder element to a physical folder on your desktop.

1. Make sure that the new folder is still selected.
2. Inthe Properties pane, click Path.

3 Click [:J.

4. Select Choose folder.
Select Create new and create a new folder on your desktop called Input flow 1.
6. Click Select folder.

o

Note: With a production workflow, the folder being linked to can be anywhere on the
network. As long as the Switch Server can access the shared volume, it can link to
the folder.

Add a second folder.

Name this folder Sort for PDEF. This will remain an Auto-managed folder. We recommend
using auto-managed folders for intermediate folders within a workflow, so files are not
moved unnecessarily over the network.

Add two more folders to the upper right and lower right of the Sort for PDF folder.
Name the top folder PDF's and the bottom folder A11 other files.
To take care of files that (for any reason) cannot be processed, add a Problem jobs flow

element.
Your flow now looks like this:
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Problem jobs

POFs

Input 1 Sort: for POF

all ather Files

7. Connect your Folder elements (but not the Problem jobs element!).
a. Double-click the /nput T folder.
A connection appears.
b. Move your cursor to the Sort for PDF folder and click that folder.
A connection is made between the two folders.

c. Make a similar connection from Sort for PDF to the PDFs folder and the All other files
folder.

Note: Always start a connection with the folder from where the files will “flow from"
and then connect to the folder they will move to. Connections have a direction of flow
noted by the arrow in the middle of the connection.

Your flow now looks like this:

Problem jobs

PDFs

Input 1 Sort for PDF

All other files
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8. Now change the connection settings, to make sure that PDF files are moved to the PDFs
folder, and all other files to the All other files folder.

a. Click the connection between the Sort for PDF and PDFs folder.
The connection highlights in dark gray.

In the Properties pane, select the Include these jobs property.

Click and select Define file types from the pop-up menu.

1. In the Define file types: Include these jobs dialog, select Adobe PDF (*.pdf).
2. To add it to the include list (right side], click Add.

3. Click OK.

Click the connection between the Sort for PDF and All other jobs folder.

. Inthe Properties pane, select the Include these jobs property.

f Click and select All other jobs from the pop-up menu.

Now your flow is complete.

9. Save the flow.
To do so, click the Save Flow button at the top of the design window.

10. Activate the flow.
To do so, click the Activate Flow button at the top of the design window.

The design window with the flow should turn gray with numbers showing "0" for each folder
in the flow. The numbers tell you how many files are in that folder at any given time.

Your flow now looks like this:

.D.

-
Problem jobs
(o]
: I:l: 0 FDFs
Input 1 Sort for PDF
a
All other files

11. Drop your test files in the flow input folder on your desktop.

You can use your own files (PDF and non-PDF) or you can use the sample files found in
“Tutorial Job Folder” folder.
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Switch will recognize these files within 10 seconds (which is the default scanning time for
an input folder) and you will see the counter change to match the number of files in the
folder. Shortly after, the end folder counters will increment with the proper number of files
depending on the sorting.

12. To check the results, click the PDFs folder or the All other files folder.
In the Jobs pane you can view what files are in these folders. PDFs should be in the PDFs
folder and all other file types should be in the All other files folder. If they are not, then
double-check the Connection settings (see step 7) and try the flow again.

Note: You can delete files from the output folders by clicking the file name in the
Jobs pane and pressing the Delete key.

4.6. Exercise 2: Sorting by file name pattern

Instruction

Duplicate the flow you created in exercise 1 and change the sorting method; instead of sorting
based on file type, now the input should be sorted on file name pattern:

* If the file name contains Part1 (e.g. JobsPart1.pdf or Part1_jobs.pdf), it should be moved to
the PDFs folder.

e All other files should be moved to a folder named All other files.

Note: This type of flows can be useful when receiving files from a Web to Print system,
or for any workflow where the file name can contain file name patterns to identify job
type, color model or other characteristics that are important to your workflow.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

* Review the step-by-step solution.

e Check the result in your own copy of Switch. To do so, import Tutorial 1B Flow.sflow
(included in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.

e Have a look at the video explaining how to build this flow http://youtu.be/GIwDS8kvnvw.

4.6.1. Exercise 2: Solution

This topic explains how to duplicate a flow and change the sorting method from sorting based on
file type to sorting based on file name pattern.

In this example, if the file name contains Part? (or part1), it should be moved to the PDFs folder;
all other files should be moved to All other files.

1. Duplicate Tutorial 1 Flow.

a. Inthe Flows pane, click Tutorial 1 Flow.
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b.

Right-click and select Duplicate flow.

2. Rename the flow.

a.
b.

In the Properties pane, select Name.
Replace Tutorial 1 Flow [Copy] with Tutorial 1B flow.

3. Define the new settings for sorting.

a.
b.
c.

Select the connection between Sort for PDF and PDFs.
In the Properties pane, click the Include these jobs field.

Click and select Define file patterns from the pop-up menu.
In the Define file patterns: Include these jobs dialog, type *partl* and click OK.

The asterisk (*) is a wild card character. The case of the characters is not taken into
account; *part?* will match Part1, partl, PART1 and so on.

S Define file patterns: Include these jobs rz|

& File matches the filker if its filename matches at least one of the patkerns.

Enter one or more filename patterns (such as *.pdf or #?Job.*); enter one pattern per
lirme

*part1*

(0] 4 ] [ Cancel

4. Check your results.

a.

Save and activate the flow.

b. Add relevant input files, for example the two tutorial 1 PDF files.

C.

Check the content of the PDFs and All other files folder (in the Jobs pane).

Job_Part1.pdf should be routed to the PDFs folder; Job_Part2.pdf should be routed to the All
other files folder.

41



Switch

5. Working with Switch

This part of the QuickStart explains some more advanced topics, such as working with sample
jobs, submitting job folders and passing data from one flow to another.

0.1. Using embedded metadata and file information

Switch allows you to use job information that is embedded inside a job, as part of the file, for
example within XMP metadata, EXIF or IPTC tags. You can use this information to sort jobs, or
use it as a reference in e-mail messages.

Note: Switch also supports metadata datasets stored as external files associated with
the job. If this is XML, XMP or JDF metadata, then Switch offers convenient access to the
metadata file content. For other file types (TXT etc.), script expressions can be used to
access the file content.

Some examples of embedded metadata

e Number of pages
e Author

e Creation date

e Paper type

Example use cases

To decide whether or not a job must be sent to an ink optimizer, you can use the information
about the paper type (coated versus uncoated] embedded inside the job; to sort jobs based on
quantity, you can use the information about the number of copies...

If you want to send an e-mail notification to the customer, you can either manually enter the
customer’s e-mail address, or you can extract the customer's e-mail address from the job. You
can also refer to the customer's reference number, or other relevant metadata.

Note: If the job was submitted via e-mail, the sender’s e-mail address is automatically
stored in the metadata dataset, associated with the job. So you can later extract this
address to send e-mail notifications.

Variables
In Switch, metadata can be accessed by means of variables.
There are two types of variables:

e Switch variables, which are not related to a particular job, such as [Swich.FlowName],
[Switch.Language], [Switch.ServerName] ...

e Job-related variables, such as [Job.Size], [Job.EmailAddress]...

When jobs are being processed, these variables are replaced with actual values. To see these
variable values, you should run a "sample” or trial job. Refer to About sample jobs on page 43.
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How to use embedded metadata in Switch

¢ If you want to use metadata to sort jobs, you must select a Connection flow element and

exclude or include jobs using Conditions with variables.

Include these jobs

All jobs
Exclude these jobs

All other jobs
Define file types
Define file patterns

Define reqular expression

N

Define condition with variables

Define script expression

Defining a condition with variables on page 45

e |f you want to use metadata in e-mail notifications, you must select a flow element that

supports attaching e-mail notifications to the job (e.g. Folder element) and select Define
multi-line or single-Lline text with variables. The attached e-mail information (addresses,

body text) can later be used by the Mail send tool to send the e-mail notifications.

Attach email addresses Single-line text with vi
Attach email body text Multi-line text with va
Attach job state Single-line text with wi
Set job priority Mone

Show in statistics Mo

Defining text with variables on page 46

5.1.1. About sample jobs

Inline value

Edit multi-line text

Define single-line text with variables
Define multi-line text with variables

Define script expressicn

Switch

Sample jobs are trial jobs.

If you have used variables to configure conditions (for example to sort or rename jobs) or to
define text (for example to customize e-mail notifications), sample jobs allow you to check the

actual values of these variables for a particular job.

Note: Switch can only display variable values if the flow contains at least one valid

sample job.

Sample jobs are also useful to check what's going on at each step of the flow.

How does it work?

Once you have designed a flow, you must set one of the connections, before the end of the flow,
on hold. When you activate the flow and input a job to the flow, the job will remain in the folder
just before the “on hold” connection, and you will see it appear in the Jobs pane.
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Note: As soon as a job is submitted to Switch, it receives a unique name prefix. Switch
uses this prefix to identify jobs. Note that only jobs receive a prefixed name; files inside a
job folder (e.g. an InDesign folder) do not receive a prefix.

Prefixes can be stripped at the moment the job reaches the flow output folder (i.e. folder
without any outgoing connections). When the prefix is stripped, the job is considered
processed and Switch has no control over this job anymore.

Example
Chedk single pages K
MNOK
. N
( Jobs )
S
Size Mame Type Modified Job Prefix
4 | & Checksingle pages [1] File Folder 12/13/2013 3:25:01 PM
445 .. '@] test.pdf pdf File 1172472008 11:01:22 AM Q0014

In the above example, the Check single pages folder element contains 1 file (test.pdf with prefix
0001A).
When you now click the Inspect jobs button in the toolbar or when you open an editor that

supports variables (e.g. if you are selecting the Connection property Include these jobs), you
will see that the sample jobs are available in the dialog, and can be used to define conditions for

sorting the incoming files.

B Define condition with variables: Include these jobs M
Sample jobs
Size _Tyoe ~ [Modified Joborefi
| ﬁ:] test.pdf 446 ME pdf File 11/24/2008 11:0... 00014
T T ] T
Condition
sSelect a variable s [: [qu-k!l ta = cSpecify a values E] Text
- -
[8].4 " Cancel ]
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5.1.2. Creating a sample job

A sample job allows you to see sample variable values in a flow, for example to make it easier
to define conditions for the connections or text/e-mail addresses that will be used in e-mail
notifications.

For more information, refer to About sample jobs on page 43.

To create a sample job
1. Create and design the flow.
Save and activate the flow.

Put a connection at the end of the flow on hold.

N @b

Place test jobs in the flow and let them process to the desired stage.

5. Deactivate the flow.

The sample jobs are visible in the Jobs pane. They have a unique prefix. When you click the
Inspect jobs button in the toolbar or choose the Flow > Inspect jobs menu option, you will see
the sample jobs at the top of the property editor. This is also the case if you open a property
editor that supports variables.

5.1.3. Defining a condition with variables

Variables allow you to use information embedded inside a job, and use this information to define
conditions for example for including or excluding jobs. Conditions always consists of a variable,
an operator, and a value (this can be a fixed value or another variable).

For example, if you want to sort jobs by the number of pages they contain [more or less than
100 pages), you should define conditions such as "[Number of pages] <= 100" (for the first
connection) and "[Number of pages] > 100" (for the second connection).

To define a condition with variables
1. Select a Connection element.

2.
In the Properties pane, click Include/Exclude jobs and select > Define condition with

variables.

3. Select the sample job for which you want to see the sample values for variables.

To be able to see the sample values, you need at least one valid sample job. Refer to
Creating a sample job on page 45.

4. Define the condition, starting with the first element (always a variable).

a.
Under Condition, next to the first field at the left, click [:]
b. Search for the variable you need.

Select a group (from the first column), and a variable belonging to that group (from the
second column). In the third column you will find information about the selected variable
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and (at the bottom) the value of that variable as found in the sample job (if the variable is
job-related).

Note: If the variable is not job-related (like Switch.FlowName), the sample value
of the variable will be the same, regardless of which sample job you select.

For example, the variable "Number of pages” can be found in the group Stats.

Depending on the selected variable, you may have additional options (displayed at the
right), e.g. in case of dates, to define the format of that date.

c. Click Insert variable.
The Text with variables field (below the columns) shows the selected variable.

d. Click OK.

5. Now select an operator from the list (next to the selected variable).
For example: Equal to, Contains, Matches, ...

To enter a value, click (next to the second field).

e To enter a fixed value, select Inline value and type the required value in the text field.
e To enter avariable value, i.e. a variable, select Define single-line text with variables and
proceed as explained in step 4.

The Sample value indicates whether or not the sample job matches the defined condition.

For example, if the sample job has 20 pages and the condition states that Number of pages >
100, the value in this field will be "false”.

L

To add more conditions as required, click
steps 4-6).

and define another condition (repeat

8. Click OK.
The value of the Include/exclude these jobs property is set to Condition with variables
defined.

5.1.4. Defining text with variables

Variables allow you to use metadata information for a job, and use this information (for example
the customer or its reference number) in e-mail notifications.

To define text with variables

1. Select a flow element that supports attaching e-mail information, such as the Folder
element.

2. Inthe Properties pane, click Attach email addresses or Attach email body text (depending
on what you want to configure).

Select [:] > Define multi-line/single-line text with variables.

4. |If a dialog pops up, type the required text or e-mail addresses, and click Define variables to
insert a variable.
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If you selected Define single-line text with variables, no dialog pops up. Proceed with the
next step.

Select the sample job from which you want to see sample values for variables.

You need at least one valid sample job. Refer to Creating a sample job on page 45.

Search for the variable you want to insert:

a. Select a group (from the first column).

b. Select a variable belonging to that group (from the second column).
In the third column you will find information about the selected variable and (at the
bottom) the value of that variable as found in the sample job. Depending on the selected
variable, you may have additional options (displayed at the right], e.g. in case of dates, to
define the format of that date.

c. Click Insert variable.
The Text with variables field (below the columns) shows the selected variable.

Note: You can put more variables in this "text with variables’ field as well

as any extra text. When the jobs will be processed in this flow, the variables

will be replaced with their actual values. For example, a line like "The
[Job.NameProper] has size [Job.Size] bytes" will be replaced with something like
"The testfile has size 5412 bytes™ and this new line will be used as the value of
the property (for example, attached as e-mail body if the corresponding property
is involved).

d. Click OK.

If you selected Define multi-line text with variables in step 3, to insert more variables,
repeat steps 4 to 6.

If you selected Define single-line text with variables, all variables must be inserted at once.

8. To close the dialog as required, click OK.

5.1.5. Checking variables for a particular sample job

To check the value of a variable for a particular job

1.

Create a sample job.

See also Creating a sample job on page 45.

Do one of the following:

e Click the Inspect jobs button in the toolbar.

e Choose the Flow > Inspect jobs menu option.

Make sure that the flow is deactivated, otherwise the Inspect jobs option/button will be
grayed out.

The Inspect jobs dialog pops up. In the upper part of the screen, all jobs that are present in
the flow are shown.

3. Select the job that you want to inspect.

4. Select the variable you need by selecting the appropriate item in each column.
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For example, if you want to check the date the job was processed by Switch (represented by
the Switch.Date variable):

* Inthe first column (Groups), select Switch.
e Inthe second column (Switch variables), select Date.
e In the third column, enter the format of your choice, e.g. dd.MM.yyyy

The value is shown in the lower part of the third column. If there's no value specified, you'll
see the string 'Sample value'.

5.1.6. Exercise 3: Sorting files by information contained within the
PDF file

5.1.6.1.

Instruction

Duplicate the flow you created in exercise 1 and change the sorting method; instead of

sorting based on file type or file name pattern (exercise 2], now the input should be sorted on
information from within the PDF file. In this example, only documents with a trim box size of 144
x 252 pixels should be routed to the PDFs folder.

Note: Other information that could be used to sort files is for example: page width and
height, page count or color model used.

This method can be useful to confirm or use information that is native to the PDF files you're
processing.

For example, if you have a workflow for business card production, you may want to confirm the
files entering the workflow are business card size. This would allow you to look at the actual
size defined within the file and confirm it's correct before processing.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

e Review the step-by-step solution.

e Check the result in your own copy of Switch. To do so, import Tutorial 1C Flow.sflow
(included in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.

e Have a look at the video explaining how to build this flow http://youtu.be/GIwDS8kvnvw.

Exercise 3: Solution

This topic explains how change the sorting method from sorting based on file type to sorting
based on variables.

In this example, only files with a trim box size of 144 x 252 pixels should be moved to the PDFs
folder; all other files should be moved to All other files.

1. Duplicate Tutorial T Flow and name it Tutorial 1C flow.

2. Set the connection between Sort for PDF and PDFs on hold.
a. Select the connection between Sort for PDF and PDFs.
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b. Right-click and select Hold.
Alternatively, you can set the Connection property Hold jobs to Yes.

This stops the flow and holds the input in the Sort for PDF folder. This will allow Switch
to use this PDF as an example when defining a condition with variables.

3. Save and activate the flow.

4. Add a PDF file (e.g. Job_Part1.pdf] to the flow.

r

Once the file has been moved to Sort for PDF, click Stapflow tg stop the flow.

Define the sorting parameters.

a. Select the connection between Sort for PDF and PDFs.
b. Inthe Properties pane, select the Include these jobs field.

Click and select Define condition with variables from the pop-up menu.

5 Define condition with variables: Include these jobs

Sample jobs
Mame Size | Type Modified Job prefix Flow element
Job_Partl.pdf 61,4 KB pdf File 11/29/2011 12:0... 00046 Sort For PDF
Condition
|[Stats. TrimBoxHeight] [.-] [Equalta v 144 [>] Rational
|F'-ND V| |[Stats.TrimBu:uxWidth] "Z] |El:|ua| to v| |252 |ﬂ R atianal
—_— W
Sample value
|true |
[ Ok ] [ Cancel ]

In the Define condition with variables dialog the test file is listed (as shown above).

Under Condition, next to the first field, click E] to edit the variable parameters.
The Define text with variables dialog lists all the variables available for selection.

e. Select the file at the top of the Define text with variables dialog and set the variable
condition as follows:

1. From the Groups column, select Stats.
2. Inthe Variables column, select TrimBoxHeight.

Note that the values in the column to the right change as you make your
selection.The value of the selected variable in the test file (in this example: the
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height of the trim box in Job_Part1.pdf, i.e. 144 (pixels)) is displayed in the bottom
part of the 3rd column.

3. Click Insert variable.

The Text with variables field displays the variable that will be used for sorting the
input files, in this example: [Stats. TrimBoxHeight].
4. Click OK.
f. Inthe Define condition with variables dialog, select Equal to and type 144.
You have defined the first condition.

9. —
To add a second condition, click I—I and select AND.

h. Repeat the previous steps, to define an additional condition, i.e. set the required trim box
width to 252.

i. Click OKto complete the setup.

7. Check your results.

a. Select the connection between Sort for PDF and PDFs.
b. Right-click and select Release.

Alternatively, you can set the Connection property Hold jobs to No.
¢. Save and activate the flow.

d. Draganddrop Job_1.pdf and Job_2.pdf into the /nput T folder within the flow.
Job_1.pdf is moved to the PDFs folder and Job_2.pdf is moved to the All other files folder.

0.2. Working with job folders and subfolders

As explained earlier, Switch accepts both files and folders (such as InDesign folders] as input,
and moves them along the flow as one entity. However, sometimes single files that have to

be processed as separate files are also submitted in a hierarchy of subfolders, for example
because the customer sorts them by project or by date.

Switch cannot distinguish between real job folders (to be processed as one entity) and files in a
subfolder hierarchy (to be processed as separate files), unless you use one of the following flow
elements dedicated for working with hierarchy structures:

The Ungroup flow element

The Submit hierarchy flow element
The Set hierarchy path flow element

The Archive hierarchy flow element.

5.2.1. The Ungroup flow element

The Ungroup element, used in combination with the Assemble job element, allows you to
process files separately, while keeping track of their original place in the folder structure.
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How does it work?

1. The Ungroup element, placed at the beginning of the flow, disassembles the input files that
enter the flow in a particular subfolder structure into separate files.

2. Each of these files is processed separately (depending on the elements in the flow).

3. Atthe end of the flow, an Assemble job element is used to re-assemble the files into a job
folder that is identical or similar to the incoming job folder.

Note: The Assemble job flow element offers different ways (schemes) for re-
grouping the processed jobs. If you want to restore the original folder structure
(=remembered by the Ungroup flow element), you should set the Scheme property to
Ungrouped job.

The Subfolder levels property is another important property. To make sure that all
subfolders are restored, we recommend entering a very high value (e.g. 999).

Example
D Problem jobs
Rename job Renamed files
rw
.
- - |
]
all input Ungroup job separated files Assemble job all re-assembled output

In this example, the input is:

e First ungrouped
e Thenrenamed
e Finally re-assembled

We need so many intermediate folders, because only folder elements can be interconnected
directly; between two non-folder elements, you need to add at least one folder element.

Below you can see the result of this flow: all files have been processed separately [i.e. the file
names have changed), but the folder structure is still the same.

4 [ o allinput [1] 4 | o all re-assembled output [1]
4 | testfolder2 4 | testfolder2
'E] roct.pdf 'E] processed_root.pdf
4 | sub 4 | sub
'@I sub.pdf 'E] processed_sub.pdf
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Note:

Ajob cannot be reassembled until all the files for that job are available. For example,
if some of the input files are sent to the Problem jobs folder, the job cannot be
reassembled!

5.2.1.1. Exercise 4: Ungrouping and regrouping a folder with
multiple files

Instruction

Create a new flow that supports file folders with multiple input files in subfolders. Sort the
input files by file type; PDFs should be sent to one folder (PDF); all other files should be sent to
another folder (Other Files). Then collect all files again in one folder and make sure the original
folder gets restored. Use a sample job to check how the job folders are ungrouped.

Note: Ungrouping and reassembling folders helps you to save time, because you don't
need to extract the files manually. This is useful if a folder hierarchy contains different
file types that each require specific processing. For example, if you want to convert all
images in an InDesign package to CMYK, you can sort out the images, process them
using Photoshop (with the Photoshop configurator), and finally restore the original
package, without any manual intervention.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

e Review the step-by-step solution.

e Check the result in your own copy of Switch. To do so, import Tutorial 2 Flow.sflow (included
in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.

e Have a look at the video explaining how to build this flow http://youtu.be/0Mxqci8oCuM.

Exercise 4: Solution
This topic explains how to group and ungroup a job folder.
1. Create a new flow (Tutorial 2 Flow) with an input folder (called /nput).

2. From the Flow elements pane, add the Ungroup job element to the right of the Input folder.

No settings are required. The job folders that flow through this element will be ungrouped
into their individual files. Switch will automatically remember the structure and add it to the
files as private data, so that they can be reassembled later if needed.

3. Add the following flow elements:

e /4job folders (Sort, PDF, Other files, Collect)
e 1 Assemble Job flow element
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4. Define settings to reassemble the job, This will tell the flow element to look for complete
jobs that were "Ungrouped” before reconstructing them.

a. Select the Assemble Job flow element.
b. Inthe Properties pane, select the Scheme property and set its value to Ungrouped job.

c. Change the Subfolder levels property to 2, so that it reassembles the job folder with up
to two subfolder levels. If the original job folder contained less levels, the extra level will
be ignored.

5. Add a new folder called Regroup to the right of the Assemble job flow element.

6. Connect all the elements (see screenshot).

Problem jobs
PDF
o
E L=
8y
Input Ungroup job Sort Collect Assemble job Regroup
Other Files

7. Change the connection properties to sort for PDFs (see exercise 1).

8. Check your results.

Before this flow is activated, put one of the connections on hold, so that you can see how the
job is disassembled and reassembled. The connection changes to a dashed line (see below).

PDF \\ FOF h‘“‘a‘&

Horizonkal, then wertical .,
wertical, then harizontal B
v Straight line

e Coleet
= Sork
Include these jobs ¥
Exclude these jobs ¥
Delete
Other Files Reset property values

Other Files
Copy property walues
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a. Save and activate the flow.

b. Dragand drop the entire job folder, Tutorial Job Folder into the Tutorial 2 input
folder. Note that the job folder is constructed as follows:

E test Files
E Images

%% Imagel.jpg
e |

-E‘-‘u| Image2.jpg
e |

! JobPartl.pdf
! JobPart2.pdf
—

OtherFile.xls

When the job processes, the number of files in the PDF folder increments to 2 and the
Collect folder increments to 3.
c. Click each folder and review the Jobs pane to see how the job folder has been
ungrouped.
d. Right-click the connection between the PDF folder and the Collect folder and select
Release.
This will allow the PDF files to move forward in the flow to be reassembled. Note that
the job is not reassembled until all the files for that job are available to reassemble.
e. Now review the Regroup folder.
The original folder structure has been restored.

5.2.2. The Submit hierarchy flow element

d

The Submit hierarchy element allows you to process files that are stored in a folder structure
with different levels, and to remember the original location of each of these files. Different from
the Ungroup element (which ungroups all files in a folder structure), you can configure this
element to only pick up particular files in particular subfolders.

How does it work?

Switch picks up the required files, based on the properties configured for the Submit hierarchy
element. The main properties are:
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The Path to the hierarchy root: Indicates the highest level where Switch must start searching
for files or folders to be processed.

The Subfolder levels: Indicates how many levels deep Switch must search for new files or
jobs.

Note that, if the specified level contains another subfolder, this subfolder will be considered
as one job, i.e. it will be processed as one entity, and not as a separate job.

Tip: If you are not sure about the number of levels, or if you want all files to be
processed separately (regardless of their nesting level in the hierarchy), set the
Subfolder levels property to a very high value (for example: 999).

The Process these folders property: If not all folders on the selected level should be
processed, you can set this property to No and use the following fields to include or exclude
particular folders.

Attach hierarchy info: By default, once the files have been processed, they are all placed

in the same output folder, at the highest level, unless you set Attach hierarchy info to Yes.
This ensures that the original location of the job in the hierarchy is stored with the file (in a
so called “internal job ticket”], so that it can be used to recreate the hierarchy. Note that this
property is available for other flow elements as well.

Thanks to this mechanism, you can “on the fly" (so while the job is passing different flow
elements] construct the path in which the processed job will be placed.

Hierarchy location path

The hierarchy information is stored as a hierarchy location path, consisting of one or more

segments, each segment representing the name of a (sublfolder in a nested folder structure.

The first segment represents the top-level folder. For example, the folder structure below is

stored as a hierarchy location path consisting of the segments CustomerA, Input and PDF [in that
order].

= ) Customers,

= ) Input
3 POF

Tip: Use a sample job to see how the saved hierarchy location path looks like. The
hierarchy is shown in the Hierarchy column of the Jobs pane.
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ouput
server
Jobs
Size Mamne Type Maodified lob Prefix

4 1 4 input [1]

: File Folder 12/10/2013 9:50:32...

0 by... | testhbt

tut File 12/10/2013 9:47:51... 00O5F

The Hierarchy column is not by default available. To display this column, proceed as follows:

1. Inthe Jobs pane header, right-click one of the column headers and select Show columns >
Column1.The new column (Column1) is now visible in the Jobs pane.

2. Right-click the Column1 header and select Set column header.

w

Type Hierarchy and click OK.

4. Right-click the Hierarchy column header and select Set column value > Define text with

variables.

5. Select Job (from the first column) and Hierarchy (from the second column) and click the

Insert variable button.
6. Click OK.

5.2.3. The Archive hierarchy flow element

€]

The Archive hierarchy element allows you to move processed files into a subfolder hierarchy
(instead of a flat structure, with all files in one root folder).

This output folder structure can be the subfolder hierarchy that was used to deliver the jobs
(via a Submit hierarchy element), or a different subfolder hierarchy, for example based on
which routes the job took in a flow. For example, you could move all jobs that were processed
successfully to a subfolder 0K, and files with problems to a subfolder Not OK.

How does it work?

The information needed to place the job in the appropriate location is retrieved from the job’s
internal job ticket. The hierarchy information is empty by default. It is created if the Attach
hierarchy information property of a flow element is set to Yes; if the hierarchy information was
not stored in the Submit hierarchy element, it is not available, hence it cannot be used to restore

the original folder structure.
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Note: Do not forget to set the Subfolder levels property!

5.2.4. The Set hierarchy path flow element

-
0

The Set hierarchy path element allows you to modify the hierarchy location path (stored in the
internal job ticket). This is useful to organize processed jobs in a folder hierarchy, for example
based on the result or the date of processing.

How does it work?

This element provides particular actions to change the hierarchy location path. You can add,
remove, or reverse segments (i.e. parts) of the location path. Note however that you cannot
combine different actions in one Set hierarchy path flow element. Hence, you may have to
combine different elements of this type in order to build the new hierarchy path.

Example

e Original hierarchy location path: Server\CustomerX\Input

» New path (to be used to store the processed files): Server\Customer X\Output\dd-mm-yy

In this example, the highest levels (Server (0) & CustomerX (1) ] must remain unchanged; there
are two new sublevels; one with a fixed name (=Output (2] ], the other with a variable name
(indicating today’s date) (3).

To create the new location path as in the example, two instances of the Set hierarchy path
element are needed:

e Set hierarchy path1 will be used to remove the Input segment (level 2] from the location path.
This results in Server\Customer X.

Properties:

e Action: Remove
e Startindex: 2 (subfolder level)
e Endindex: 2 (subfolder level)

e Set hierarchy path2 will be used to add two new segments: Output (level2) and today’s date.
This results in Server\Customer X\Qutput\dd-mm-yy.

Properties:

e Action: Add at the bottom (= the new segment should be attached to the end of the current
hierarchy path).

» Path segment 1: Output (= entered as an inline value)
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» Path segment 2: The [Switch.FileCreationDate] variable (entered using the Define single-
line text with variables editor)

5.2.5. Exercise 5: Receiving jobs from within a server hierarchy

Instruction

Create a new flow that processes all files stored in the subfolders with the name Incoming
(see image below). Once processed, the files must be moved to a new folder with the name
Completed, under the appropriate client name.

b . Server ﬁ‘-

v Client A ot
¥ Incoming

> R ¥
To Client

v E Client B
¥ (L] Incoming o Switch Workflows

> .
Tao Client

Pk Client C

]

Note: This type of flow is useful to work with folders with variable names (e.qg. client A,
client B, ...). If new client folders are added, the flow doesn’t have to be changed; jobs
will be processed automatically.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

e Review the step-by-step solution.

e Check the result in your own copy of Switch. To do so, import Tutorial 3A Flow.sflow
(included in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.

e Have a look at the video explaining how to build this flow http://youtu.be/-nu27qeXR-A.

5.2.5.1. Exercise 5: Solution

This topic explains how to create a flow where:
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e Anew client job or job folder is recognized within a client input folder (in this example:
Server/Client/Incoming).

e The jobis processed in Switch.

e The processed files are placed back in an outgoing folder for client review (in this example:
Server/Client/Completed).

1. Place Tutorial 3 Desktop Folder on your desktop.
This will be used to simulate a network server folder structure.

2. Create a new blank flow and rename it to Tutorial 3A Flow.

3. From the Flow elements pane, select and drag a Submit Hierarchy flow element onto the
canvas.

4. Inthe Properties pane (with Submit Hierarchy selected], rename the flow element and
define the actual location of the input files.

You should indicate the top-level (level 0], the number of sublevels to be checked by Switch,
the folder names that should be included or excluded, and whether or not the folder
hierarchy should be remembered.

Hierarchy

Level 0

| Server
— 1

|'_j Client A
2

v | Incoming

In this example, Switch should pick up input from the /ncoming folder of each Client folder

(see image).

a. Torename the Submit Hierarchy element to a meaningful name, set Name to From
Server.

b. To define the top-level directory path, select Path and Choose folder from the pop-up
menu.

Select the Server directory from the Tutorial 3 Desktop Folder.
c. To have Switch look two levels deep, set Subfolder levels to 2.
d. To have Switch look for folder names starting with the string /ncomin, but only on level 2:

1. Set Adjusted by (rule 1) to Excluding folders not named.
2. Set Folder name to Define folder patterns and enter Tncomin* as value.
3. Set On levels to 2.

e. To have Switch remember the complete path back where the job came from, set
Attach hierarchy info to Yes. This information will be added to the job as private data
(metadata) within Switch.

f. SetInclude subfolder levels to 2.

Since this is the same level Switch is looking for files, this will have Switch remember
the entire hierarchy. It can be modified later.

5. Mimic the flow below, by adding flow elements and connecting them.
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Problem jobs
g ig D
v 0
From Server Folder 2 Set hierarchy path Folder 4 Archive hierarchy

M Iy

-0
Set hierarchy path Folder 3

6. Define a new location for the processed files.

Note: The Set hierarchy path flow elements are used to build a new location path,
based on the original path. In this example, the original path is Server/Client/
Incoming; the new path should be Server/Client/Completed.

a. Inthe Properties pane of the first Set hierarchy path element:

1. Toremove Incoming from the original location path, set Action to Remove.

2. Toindicate the level of the hierarchy that will be removed (in this example: the
second level, being Incoming), set Start index and End index to 2.

This will change the path from Server - <Client> - Incoming to Server - <Client>.
b. Inthe Properties of the second Set hierarchy path element:

1. To add a segment at the end of the hierarchy path, set Action to Add at the bottom.

2. To enter a name for the new segment, click Path segment 1 and select Inline value
from the pop-up menu.

3. Enter a name, in this example: Completed.

7. Now define the properties for the Archive hierarchy element.
a. Set the Path to the original input location (see the Server element in your flow).
b. Change Subfolder levels to 3.

The Subfolder level indicates the number of subfolder levels to be created. The
embedded hierarchy will make sure that the original position is maintained [i.e. that files
are stored in the correct Client folder], while taking into account the changes made in
"Set hierarchy path" (i.e. so that output files are placed in the Completed instead of the
Incoming folder).

c¢. To maintain the file original names, set Strip unique name to Yes.
This means that the unique prefix name added to the file name by Switch is removed
before placing the job in the archive hierarchy.

d. Toindicate what should happen in case of duplicate file names, choose a value for
Duplicates, for example: Overwrite.

60



Switch

8. Check the result.
a. Save and activate the flow.
b. Place a new job in one of the input folder (e.g. in Server/Client B/Incoming).
This can be a folder or a single file (any file can be used).
c. Check the output.

The output should be found in a new subfolder of the same Client folder (e.g. in Server/
Client B/Completed).

Client B Client B
Incoming Completed
!. JobPartl.pdf !. JobPartl.pdf
Client C Incoming
Incoming Client C

Note: If you need to access a secure FTP server to receive your files, the procedure is
similar. However, you will need to use FTP Receive (instead of Submit Hierarchy) and
FTP Send (instead of Archive Hierarchy).

5.3. Connecting flows and retaining hierarchy
iInformation

Switch allows you to connect two flows (each doing part of the processing), while remembering
the original folder structure, so the files can be placed in the right folder.This is useful if a
process is divided over two different workflows, for example the images are processed in one
workflow and then rejoined to a layout document so a PDF can be created with the modified
images.

How does it work?
To connect two flows, you must make sure that:
e The ouput folder of the first flow is linked to the input folder of the second.

e The Strip unique name property of the output folder of the first flow is set to No. This way,
the unique job prefix is preserved when jobs go from the first flow to the second flow.
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If the first flow places the processed files in the output folder, these files can be picked up
immediately by the second flow.

5.3.1. Exercise 6: Passing hierarchy info to another flow

5.3.1.1.

Instruction
Modify two flows created in the previous exercises (flow 3A and flow 2) so that:

e The first flow captures and modifies the hierarchy data;

e The second job processes the result of the first flow and uses this hierarchy information to
put the files back in the appropriate folder.

Test files

Download the test files: http://www.enfocus.com/manuals/Extra/Switch/Switchtutorial.zip

Solution

e Review the step-by-step solution.

e Check the result in your own copy of Switch. To do so, import Tutorial 3C Flow.sflow
(included in the zip package, under Tutorial Flows) by selecting Flows > Import Flows.

* Have a look at the video explaining how to build this flow http://youtu.be/-nu27qeXR-A.

Exercise 6: Solution

This topic explains how to pass hierarchy information from one flow to another. This is done
by linking the output folder of one flow to the input folder of the second flow, and by adding an
Archive hierarchy element to the end of the flow.

1. Duplicate "Tutorial 3A Flow"” and rename it Tutorial 3B Flow.
2. Duplicate "Tutorial 2 Flow" and rename it Tutorial 3C Flow.

3. From Tutorial 3B Flow, copy Archive hierarchy and paste it into the new Tutorial 3C Flow. .

a. Select "Archive hierarchy”.
b. Right-click and select Copy.

All properties will be retained.
c. Switch to Tutorial 3C Flow, right-click in the canvas area and select Paste.
d. Place the Archive hierarchy element near the end of the flow.

4, Switch back to Tutorial 3B Flow and delete the Archive hierarchy flow element.

5. Link the last folder in the flow (Folder 4] to an external folder called Workflow Input 3C.
Your Tutorial 3B Flow should now look like this:
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6.

Problem jobs

o &d

From Server Folder 2 Set hierarchy path Warkflow Input 3c
Set hierarchy path Folder 3

In the Properties pane of Workflow Input 3C, set Strip unique name to No.

This avoids that Switch removes private data (such as the hierarchy information) from the
files.

Switch to Tutorial 3C flow for editing.

Link the input folder of Tutorial 3C flow to the output folder of Tutorial 3B flow.

a.
b.
c.

d.

Select the Input folder.
In the Properties pane, click Path.

Click E] and select Choose folder.

Select the Workflow Input 3c folder on your desktop.

Now when the Tutorial 3B flow places a file in this folder, the Tutorial 3C flow will detect it
for processing.

Make a connection between the Regroup folder and the Archive hierarchy element (copied
from the Tutorial 3C flow).

This makes sure that processed jobs are placed back in the correct folder.

Problem jobs
PDF
) [
a
Input LIngroup job Sort Collect Assemble job Regroup

)

Other Fil
=res Archive hierarchy
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10. Check the result.

a. Save and activate both flows.

b. Place the Tutorial Job Folder folder in any of the Client Incoming folders within the
tutorial hierarchy.
If successful, the processed Tutorial Job Folder folder is placed in a new subfolder called
Completed. This should take about 20-30 seconds in total to process.
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